What's new
  • Please do not post any links until you have 3 posts as they will automatically be rejected to prevent SPAM. Many words are also blocked due to being used in SPAM Messages. Thanks!

2560x1440 with 7850 2GB... shouldn't be a problem... but I'm having problems

bigFOIG

Well-known member
Joined
Apr 4, 2011
Messages
407
Location
Vancouver, B.C.
Using an Asus 7850 2Gb with my Achieva Shimian 2560x1440 monitor. All drivers are updated (mind you I am using beta AMD drivers but I don't feel like this would be the problem).

Youtube videos at 1080p are choppy as hell and not even close to being watchable. 720p is better but still really choppy. And I feel like even the 480p videos could be smoother.

Re-watched Finding Nemo with my GF (in preparation of Finding Dory of course...) at 1080p with my computer and the movie would have stretches of super lag every few minutes.

I have not tried playing any games yet. I know I won't be able to game with this video card at this resolution. Only need smooth HD playback.

IIRC, I used a much weaking nVidia card with this monitor before and the 1080p youtube videos were only a tiny bit choppy. What am I missing here?
 

Bond007

Well-known member
Joined
Jun 24, 2009
Messages
6,893
Location
Nova Scotia
Out of curiosity did you try dropping the output resolution going to the monitor to 1080p and then watch the same video?
 

bigFOIG

Well-known member
Joined
Apr 4, 2011
Messages
407
Location
Vancouver, B.C.
I'm having a feeling that this has something to do with flash.... I mean, turning down the system res down to 1080p didn't make a difference. I've tried both firefox and chrome.
 

sa seba

Well-known member
Joined
Feb 9, 2008
Messages
303
Location
Vancouver, BC
Have you tried to play a flash based video with hardware acceleration disabled? This would circumvent any issues that flash might have with your 7850.
 

bigFOIG

Well-known member
Joined
Apr 4, 2011
Messages
407
Location
Vancouver, B.C.
Hardware acceleration disabled makes no difference. I feel a bit silly not posting up my full specs though. I'm using a temporary rig right now until Haswell comes out.

Asus P5B
Intel Core 2 Duo E8400
4GB DDR2 RAM
Asus Radeon HD 7850 2GB

Surely the E8400 wouldn't be a problem would it?
 

bigFOIG

Well-known member
Joined
Apr 4, 2011
Messages
407
Location
Vancouver, B.C.
Well... it's youtube... It's a flash media player?

If you're wondering what I used to watch my movie, it was VLC Media Player, but I didn't really have too many problems with that.
 

Latest posts

Top