What's new
  • Please do not post any links until you have 3 posts as they will automatically be rejected to prevent SPAM. Many words are also blocked due to being used in SPAM Messages. Thanks!

Asrock Z77 Extreme 4 Video Card Problem


New member
Jul 21, 2012
Hi All,
I'm from Australia and I'm new to the forums and its a shame that my first post has to be be about an issue I'm having with my one day old system.
Just wanted to say I'd appreciate any help that I can get.
First of all I'll give a quick spec breakdown of what I have.
Asrock Z77 Extreme 4 motherboard using the latest 2.00 bios.
i5-3570K Intel (ivy) cpu at stock
16 gigs of G-Skill Ares ddr3 ram
Msi R7850 Twin Frozr III 2gig oc graphics card
Corsir SSD
Corsair H60 Water cooling unit.

Ok here's the problem.
Initially the video card (the MSI) was not being detected at all by the system and I had to use the onboard Intel HD to be able to get into the bios.
Once in the bios I went into the Northbridge category of the advanced options and ensured that the video options were set to pciexpress.
At this point the two options for slots pcie2 and pcie3 link speed were set to Auto, as they should be.

The only way that I have been able to get my motherboard to successfully detect the MSI video card is by changing the link speed for the pcie2 slot to the GEN1 option!
Once this is done, the system has no problem running the video card as its output.
Of course once your boot into windows 7 and run GPU-z, it reveals the card running at x16 1.1 instead of 3.0 or even 2.0
I've done a cmos reset back to defaults and of course this then changes the settings back to AUTO and I'm back to square one.
Apart from this issue, the system runs extremely well.
I haven't done any benchmarking or played any games as yet but I'm expecting to see some degradation of performance because of the "bottlenecking" that this issue may cause.

Can anyone out there assist me at all with advice, or a work around or even examples of similar cases where this has happened.
I paid $155au for the board itself and although I'm not flush with cash, I would buy another board just to get the system right.
Please help :)
Thanks again.


New member
Jul 21, 2012
Not sure the issue I had/have is same, but try this

When I first built the board I was using 1 x discrete graphics card and connected a single monitor to the DVI port, it was coming up blank, I moved the card to the 3rd slot and bang it worked great, only issue is that slot is 8x only however it's been proven no card takes advantage of full bandwidth of pcie 3.0 16x anyway.

I then purchased a second card and setup crossfire, moved the monitor to the card in slot 1 and bang it worked very strange but great it works.

Now this is where it gets interesting, I upgraded to a 7970 (previous cards were 7770), in the meantime I purchased 3 monitors and setup eyefinity, once I changed out the card I decided to try both slots, this is the really interesting part.

Slot 3 (middle of board) would post all 3 screens (1 x DVI, 1X HDMI, 1 x DP), and came up as PCIE 3.0 x 8.

Slot 1 (Closed 16x to the CPU) would post only 2 screens, HDMI & DP but not the DVI, however DVI comes up once in windows.

This has been happening to me since 1.2 and I'm now on 2.0 and still persists however given I get everything once in windows and 2 screens show post I haven't been bothered.

I recommend you try 2 things.

1. Try plugging into HDMI if yours is in slot 1.

2. Try card in Slot 3 (middle of board), this will give you 8x but I can confirm that even with 7970 there is no performance drop at all, I got over 10,000 P in 3dmark after overclocking my 7970 proof here AMD Radeon HD 7970 video card benchmark result - Intel Core i5-3570K Processor,ASRock Z77 Extreme4 score: P10305 3DMarks

Hope this helps


BTW: I'm an Aussie :)


New member
Jul 21, 2012
My apologies, can a moderator move this to the troubleshooting thread please?


New member
Jul 21, 2012
Looks like i may have solved the issue.

I decided to have a go at downgrading the bios to an older version.
I started with version 1.40 downloaded from the Asrock site.
Flashed the bios from within windows and restarted the pc.
I did expect my main monitor to blank out with my small number two monitor (pdf reader) to remain on as I had this one connected to the Intel onboard dvi.
Low and behold the main monitor fire up immediately!
I went straight into the bios and checked the northbridge settings for the pcie link speed.
It was now sitting at AUTO which is normal but in this instance the 7850 had been detected successfully.

I booted into windows and then flashed the bios to 1.80 expecting the board to die again, but nope it booted and detected the 7850 again!
Third times the charm, booted to windows and flashed to 2.00 (the latest at the time of writing) and voila...still working.

Next I disabled the power management function in windows 7 for pcie and fired up gpu-z.
GPU-z still showed the card at pciex16 1.1.
So i ran the render test to see if the card would ramp up and it did successfully did so reading pciex16 3.0 under load.

I hope this helps someone else.
Now i'm about to conduct one last test; reset the cmos and see if the bios recovers.
Wish me luck.:shok:


New member
Jul 21, 2012
A bios reset failed.
The board went back to showing no card installed.
i contacted the vendor i bought the board from who offered me a refund.
So im going to buy a gigabyte board instead.

Latest posts