What's new
  • Please do not post any links until you have 3 posts as they will automatically be rejected to prevent SPAM. Many words are also blocked due to being used in SPAM Messages. Thanks!

Asus 670 BSOD's on startup after driver install

Soullessone21

Well-known member
Joined
Oct 30, 2011
Messages
1,281
Location
Calgary AB
need help just upgraded to a 670 CUII and it BSOD during windows startup the restart after the drivers are installed :(. Tried both asus and Nvidia drivers. any help would be great
 

SugarJ

Moderator
Staff member
Joined
Jan 17, 2008
Messages
6,911
Location
Langley, BC
Did you clean the drivers from your AMD card in safe mode before you shut it down and installed the Nvidia?
 

Soullessone21

Well-known member
Joined
Oct 30, 2011
Messages
1,281
Location
Calgary AB
That I did my good sir, still having the issue just ran out to my computer storage room and grabbed the driver disk remember that my old 6870 only would install the first time with the asus driver disk maybe this Asus 670 is just buggy like it was that way.
 

ilya

Well-known member
Joined
Feb 26, 2010
Messages
1,562
Location
Markham
If you can run a GPU benchmark in Linux or a separate Windows install, you can pretty much guarantee it's a driver issue.
 

Soullessone21

Well-known member
Joined
Oct 30, 2011
Messages
1,281
Location
Calgary AB
Looks like I am SOL time to try a reload if that fails nvidia will again be on my hated list and I will go get a 7950
 

Dzzope

Well-known member
Joined
Oct 15, 2010
Messages
3,299
Location
Irishman in Kiev, wOOoo, I'm an alien...
I had a crash issue with my 670 but it would get into windows first... i found the GPU tweak software was the cause..

It is possible that you got unlucky and it's just a bad card... Which can happen with any type of card from any manufacturer..

If possible try it in a different box.
 

Soullessone21

Well-known member
Joined
Oct 30, 2011
Messages
1,281
Location
Calgary AB
... 4 machines and 2 reloads I got a bad card... I will advance swap for one more but am really disappointed this was supposed to be Nvidia's saving grace for me... I was going to swap from my 6970 and almost 6 solid years of ATI/AMD only love over to all Nvidia in my house but if I get another one back failed. I will never look back:doh:
 

supeg

Active member
Joined
Aug 11, 2011
Messages
40
Dammm. Was going to suggest driver sweeper in safe mode due to similar issue but if card is bad card is bad.
 

Soullessone21

Well-known member
Joined
Oct 30, 2011
Messages
1,281
Location
Calgary AB
good plan, I tried Drive sweeper too :thumb: great minds think alike but sadly just DOA new card is here going to try it in 3 hours haha
 

Soullessone21

Well-known member
Joined
Oct 30, 2011
Messages
1,281
Location
Calgary AB
Ended up being my server, it wont play nice with any Kelper cards, and for some reason Nvidia cards only play at half power but when I put a AMD card in it runs way smoother so back to my 6970 for now:) still a great card though
 

Latest posts

Twitter

Top