What's new
  • Please do not post any links until you have 3 posts as they will automatically be rejected to prevent SPAM. Many words are also blocked due to being used in SPAM Messages. Thanks!

ASUS AMD Motherboard (drivers issues) Crosshair V / M5A99X

ExpendableG4M3R

Well-known member
Joined
May 7, 2012
Messages
58
Well its been a fun time over here with these problems I'm having. I thought I would post here because I think I (we) need more help. I've been emailing with Soullessones21 and he can't do it all alone, hes a busy man.

So the problem is not really the motherboard because I had a ASUS M5A99X do the SAME EXACT thing.

Problem's are...
1. System will not shutdown after the Asmedia USB 3.0 drivers are installed (Does not do it the driver is not installed, but then I have no USB 3.0).
2. After Realtek drivers installed, on shutdown & restart 90% of the time there is a loud screech from the speakers (Does not do it when just Win 7 default sound driver).

Fresh install of Win 7 64, load the AMD chipset drivers, load the nVidia drivers... everything is working fine. Shuts down fine, restarts fine, no hiccups no screeching. Runs like it should.
As soon as those drivers are installed, BAM! the above mentioned problems start.

What can we do?? I've tried the latest drivers and older ones, AND this is the same problem on two boards now....:angry2:


I know this board is fine and same with the last one, its just the damn drivers that pooch it...... I might just part out this damn PC... AMD is pissing me off, never had problems with my Intel setup's. :censored:

EDIT - I've Googled this problem "Asmedia USB 3.0 shutdown problem" and there are a few people reporting this but no one seems to have a fix. No Google problems/fix for the Realtek problem though :(
 
Last edited:

supaflyx3

Well-known member
Joined
Jun 12, 2010
Messages
3,024
Location
Langley, BC
Use windows drivers for audio, and does the shutdown issue still arise when you press the power button on your case?
 

ExpendableG4M3R

Well-known member
Joined
May 7, 2012
Messages
58
Ya the shutdown wont work anyways what so ever with my wireless NIC installed with the USB 3.0 drivers.

Its just my system configuration the motherboard is fine because when I pull out the NIC it shutdowns fine with the drivers. Its just software related.


I think I was just not allowed to have this board. Most likely going to sell it to someone who could use a killer board like this and can use 100% of it, whereas I am using about 10% since I don't OC at all and just use the pc to surf the net.
 

BigPhatPaulie

Well-known member
Joined
Apr 19, 2012
Messages
439
Location
Alberta
My only thought would be its one of your components (cpu, gpu etc) but if others are having the same issue then Im not too sure​
 

norfolk

Well-known member
Joined
Mar 21, 2007
Messages
444
Location
N1R-1C8
I have had a couple of issues regarding both of my CHV boards,Audio issues include lock up, No Audio,mixed problems with THX ETC ,ETC.,
So for the audio I tried this and it works.
How to Fix X-Fi MB2 Sound Problems on Asus ROG Crosshair V Formula

If you finally want to have good quality sound from your CVH follow THESE STEPS TO THE LETTER:

1. Uninstall All Creative Soundblaster X-Fi software
(if you didn’t install that software yet, proceed to step 2)
After Uninstall you will be asked if you want to reboot youre system,
cancel this for now.
2. Now Uninstall ALL Realtek High Definition Audio Drivers (from Realtek Semiconductors Corp.)
3. Now Reboot your system.
4. Run a registry sweep program to get rid off all remaining sound settings in the Registry.
I always use: Driver Sweeper.
(Its free and you can download it at: Phyxion.net)
Run the program and clean the registry from all Sound Related Driver info from:
- Asus Sound
- Realtek Sound
- Creative Sound
5. Now Reboot your system.
6. Wait Untill Windows finishes installing drivers for new found hardware.
7. Download the latest version off the following driver:
High Definition Audio Codecs from Realtek.
Link: http://www.realtek.com/downloads/dow...&GetDown=false
8. Choose 32 or 64bits version (check your Windows version).
You can also download the larger installer containing both 32 and 64bit.
9. Current Version (as per 2012/11/02): R.67 updated on 2011/12/16
10. Install this driver.
11. Reboot your system
12. Download the latest Sound Blaster X-Fi MB 2 Utility V1.0(R11) for Windows Vista/7 32bit & 64bit from Asus
website, Link: support.asus.com. Find your Motherboard and choose 32 or 64bit,
you will find it under Download / Utilities. Current Version: V1.0(R11)
13. Install Sound Blaster X-Fi MB 2 Utility.
14. Reboot your system.
15. Go to folder in program list: Creativ/ Sound Blaster X-Fi MB 2. Click Activate
16. Start Sound Blaster Console and setup your speakers, your output port, EAX, Equalizer and THX.
17. YOU NOW HAVE EVERYTHING READY AND WORKING.

No more problems like:
- Hissing Sound (ea during Windows start, reboot, shutdown or suspend)
- Stuttering
- You CAN USE SPDIF with all Surround Speaker options (stereo, 5.1, 7.1 etc!)
- No need to buy a separate Soundcard to get great sound (as some people did unfortunately).


I have seen a lot of questions on websites and forums about this problem, but so far never seen a complete solution. All kinds of comments about hardware setup, Windows Version, Bios Version, Defective Motherboards that are RMA-ed.
Replies from Asus that the software works fine…. Yes it does but if you miss 1 little step in above described procedure it will not work.

This is all very strange and I think it arises because:
- Motherboard Manufacturers like Asus, MSI etc buy a third-party sound controller.
- In this case from Realtek (works mainly with OEMs), This is a fine Controller.
- This chip (Realtek ALC889 @ ATI SB800 - High Definition Audio Controller) needs a driver from Realtek.
- Somehow this controller is partly disabled: you can’t get more than stereo on SPDIF. No 5.1 or 7.1 can be selected.
- Manufacturers want to market their Motherboard in the best way so they buy a “X-Fi 2 SupremeFx” sticker” and put
it on the Controller on the Motherboard. A Software package from Creativ Soundblaster is bought and included
(bringing: X-Fi® Xtreme Fidelity™ , EAX® Advanced™ HD 5.0, THX® TruStudio PRO™, Creative ALchemy, Blu-ray
audio layer Content Protection, Optical S/PDIF out port(s) at back panel.
- It now looks like you have bought a motherboard with an onboard Creative X-Fi Soundblaster, this is not the case.
It is a Realtek Controller with a Creative Software Package.
- Only by installing the Creative Soundblaster X-Fi MB2 drivers (as discribed) most functions from the sound card are
unlocked.
- Now its time to get confused (that is clear ;-) when they have installed the Realtek Driver the Sound seems to be
okay and nothing in system management askes for more or other drivers.
So why install Creative Software – that’s what I thought – until strange things started to happen….
- You check your driver DVD or download site and install Creative Software …..
- And then it states: the hardware needed for this software is not installed on your system, choose other device.
But you can’t choose any other device. So now you are in a loop.
How can you install drivers for hardware that’s not there…..
- Only if you follow exact procedure.
- If you try to find drivers at creative site …. You can’t find it, because it’s not listed as official product.
If you go and search in OEM directory you can come across this:
OEM - Software Solutions - Sound Blaster X-Fi MB

- Not a word about where to get software and how to solve any problems.
- If you want Dolby Digital Live and DTS support …. You have to buy it at Creative…
- If you go to Realtek you have to really dig deep to find these drivers.
- At Asus site and forums I couldn’t get a clear picture about it too.
- If I see all these questions, lots of people complaining, RMA’s and no solution ???
This costs money and customers…

Well, this story got a lot longer than intended but my frustration about this went down a lot while writing…
I hope you benefit from my findings !!
 

Twitter

Top