What's new
  • Please do not post any links until you have 3 posts as they will automatically be rejected to prevent SPAM. Many words are also blocked due to being used in SPAM Messages. Thanks!

Catalyst 8.5

Eldonko

Well-known member
Joined
Apr 5, 2007
Messages
5,414
Location
Calgary, AB
Just came out, loads of bug fixes found here.
Catalyst™ 8.5 introduces the following new features:
• Catalyst™ Control Center Component Video
• ATI Graphics Driver Un-install Enhancement
• SECAM TV Out Support
• 1080p HDTV custom mode
• HDMI Audio for non-standard TV modes
• Adaptive AA on OpenGL for Catalyst™ Control Center
• 1080p24 Mode Support
• Windows XP Service Pack 3 support

The following performance gains are noticed with this release of Catalyst™.
• Call of Juarez DX10: Performance increases up to 12% on systems containing an ATI Radeon™ HD 3xx0 series of product
• Halo: Performance increases by 10-30% across all of the supported ATI Radeon™ series of products
• Lost Planet DX10: Performance increases from 5 to 35% on systems containing an ATI Radeon™ HD 3xx0 series of product
• Stalker DX9: Performance increases by 20-50% when HDR is enabled in the game; across all ATI Radeon™ HD38x0 series of products
• World in Conflict DX10: Performance increases up to 25% on systems containing an ATI Radeon™ HD36x0 and/or an ATI Radeon™ 38x0 series of
product. Higher performance gains are noticed on systems contianing an ATI Radeon™ 3870x2 series of product
Download
 

vinister

Well-known member
Joined
Feb 1, 2008
Messages
297
Location
Vancouver
Wow! Looks like a very significant update.

Installing right now, we'll see how it goes with triple crossfire.
 

cmac79

Well-known member
Joined
Mar 21, 2008
Messages
1,053
Location
Newfoundland
i tried the 8.5 and it messed my shit up lol i had to go back to 8.3 and now im havin probs lol.i have hd 2400 pro and after i tried 8.5 it wouldn't pick up my secondary display which is my tv. i use to watch movies. when i hit detect display the ccc would error and close so i went back to 8.3 where it always worked and it keeps erroring out when ever i detect displays
 

Jamz

Well-known member
Joined
Jun 28, 2007
Messages
80
i tried the 8.5 and it messed my shit up lol i had to go back to 8.3 and now im havin probs lol.i have hd 2400 pro and after i tried 8.5 it wouldn't pick up my secondary display which is my tv. i use to watch movies. when i hit detect display the ccc would error and close so i went back to 8.3 where it always worked and it keeps erroring out when ever i detect displays

I had the same problem before

you might have to reset your monitor...

turn off the monitor, unplug the power cable from the monitor, then unplug the monitor from the video card...

then plug the power cable back in, plug it into the video card again, and turn on the monitor.

that might work.
 

Latest posts

Twitter

Top