What's new
  • Please do not post any links until you have 3 posts as they will automatically be rejected to prevent SPAM. Many words are also blocked due to being used in SPAM Messages. Thanks!

Crossfire Issue

Rikan S-087

Well-known member
Joined
Jan 17, 2011
Messages
66
So I just upgraded to Radeon Crimson display driver 16.5.2.1 today.

I have a R9 295x GPU.

I opened the settings and checked all my game profiles and nowhere can I find the crossfire enabler toggle. I also checked "additional radeon settings" under preferences and all that is there is Eyefinity settings. There are no power efficiency settings there either (there used to be).

I have tried a a few things: I wiped all AMD driver and did a fresh install. Nothing. I wiped all AMD drivers and reverted back to the previous driver (16.5.1). Nothing and now the old version does not have a crossfire toggle either.

I am at a loss and could use some help.
 

Rikan S-087

Well-known member
Joined
Jan 17, 2011
Messages
66
The R9 295x is a dual card. It's two cards on one board. I have had it working fine in crossfire until now.
 

Rikan S-087

Well-known member
Joined
Jan 17, 2011
Messages
66
For the record, GPUz shows Crossfire enabled. But i want to tailor the crossfire in the profiles like before as some games do not run well with CF enabled. Would resetting the Cmos help?
 

bignick277

Well-known member
Joined
May 26, 2010
Messages
173
Open the crimson application -> Click "Gaming" -> Click "Global Settings" -> Click "AMD Crossfire" to Enable/Disable Crossfire.

You can also change it on a per game/application basis by creating a profile for specific game and then enabling it. There used to be another way to do it through additional settings, but that's since been removed in the latest drivers.
 

Rikan S-087

Well-known member
Joined
Jan 17, 2011
Messages
66
Not sure where the confusion is. I don't need directions on where to find the toggle! The issue is that the toggle is MISSING. Vanished. Gone.

I am not a novice computer user--very experienced with CF and the like. This is still an issue as of this very post and the latest drivers.
 

KaptCrunch

Well-known member
Joined
Feb 23, 2008
Messages
4,079
Location
Ontario
are any pci-e slots being used between GPU's

I noticed with M2 adapter on slot 2 I loose SLi

GPU's on slot 1 and 3

or a bad ribbon connector
 

bignick277

Well-known member
Joined
May 26, 2010
Messages
173


Step 1: Open up the Crimson Application and click "Gaming"



Step 2: From this screen click "Global Settings"



Step 3: From here you can see the option for disabling Crossfire. Click "AMD Crossfire" to disable it. You'll be asked to confirm before it will disable crossfire.

Take Note of the tabs at the top. You'll notice 1 tab for your graphics adapter and 2 for overdrives. Take note of this because the next bit is important. Only the tab for your actual graphics adapter is important. Disregard the overdrive tabs

If you have 2 graphics adapters or a dual GPU card and your application looks like the below picture instead. .. .



Then this likely means that Crossfire is already disabled. Notice that because the option is missing you can't re-enable crossfire from this screen. Also if you look at the top tabs, you'll notice there are 2 tabs for your actual graphics adapters now instead of just the one crossfired adapter. If this is what you see, then the system does see both of your adapters, but crossfire is currently disabled. To fix this, you need to click the tab for the second graphics adapter as shown in the following screen.



Now you can see the option needed for re-enabling Crossfire. Click "AMD Crossfire" and confirm to re-enable crossfire.

P.S. Don't bother disabling Crossfire via profiles for individual games. In my experience so far, it doesn't really work. I've only found this method works for enable/disabling Crossfire for games that don't like multiple GPU's.
 
Last edited:
Error 403 Daily Limit Exceeded. The quota will be reset at midnight Pacific Time (PT). You may monitor your quota usage and adjust limits in the API Console: https://console.developers.google.com/apis/api/youtube.googleapis.com/quotas?project=345236864347 : dailyLimitExceeded

Twitter

Top