What's new
  • Please do not post any links until you have 3 posts as they will automatically be rejected to prevent SPAM. Many words are also blocked due to being used in SPAM Messages. Thanks!

Dead asus sata3 port

TTC

Well-known member
Joined
Mar 26, 2014
Messages
295
So this constantly happens anytime I touch my ssds. One of my sata3 ports just wont work. I can attach the cord and ssd to an sata2 port and it works. The second I put it on the top sata3 it can't locate the drive. The bottom one works but not the top. Eventually after a shit ton of tooling around I can get it but this time it won t work. Also can't be found in the manager.
 

Shadowarez

Well-known member
Joined
Oct 4, 2013
Messages
1,436
Location
Arctic Canada
Sounds like the controller is pushing up daisies which is not fun but there's cards to replace those but not sure how they work booting from.
 

MARSTG

Well-known member
Joined
Apr 22, 2011
Messages
4,313
Location
Montreal
but there's cards to replace those but not sure how they work booting from.

Usually the add-in cards are in AHCI mode and normally Win7 will install it's own regular MS AHCI driver. Is just like any sata port, you just need to make sure you have the correct drive selected in BIOS for boot, that's all. You just install the cart, install the driver, reboot, driver is installed, you can shut down the system, attach your drive to the controller, reboot, and the drive is booting on the new controller. You will probably hit a speed penalty as well, most probably, as these add in sata III chips are not as fast as the integrated ones. But they work just fine for situations like these.
 

Latest posts

Twitter

Top