What's new
  • Please do not post any links until you have 3 posts as they will automatically be rejected to prevent SPAM. Many words are also blocked due to being used in SPAM Messages. Thanks!

Help with 4890 fan Please

AdoP

Well-known member
Joined
Aug 16, 2009
Messages
120
Location
Guelph/ Toronto
I just picked up a used ATI brand OEM 4890, I have tried 9-9 and 9-10 drivers and have absolutly no control over the fan speed. I ran furmark for 10 sec and the temps went up to 90c because there is no change in fan speed it just spins very slow. I have a corsair HX 1000w power supply and a full tower HAF 932 and I have run 4890's it before with no problems. The guy I got the card from said that he had never tried it for games/benchies and that I can have my money back but hopefully someone can help me fix the problem.

The card has its stock heatsink and it has never been removed.
 

MarkOne

Banned
Joined
Oct 19, 2009
Messages
4,010
Location
Chertsey 60 KM north of Montreal
1- you open ATI catalyst
2- chose overdrive in the menu





3- you have to check the enable overdrive






4- and after enable manual fan control

of course mine is not enable , I have a thermalright rad with fan always at 100 %
 

sswilson

Moderator
Staff member
Joined
Dec 9, 2006
Messages
17,899
Location
Moncton NB
Do you have the original install disk for the card? Just a shot in the dark, but I've had a few cards which needed the proprietary drivers installed initially for settings like fan control to work. Once they were installed I was able to install the most recent drivers while still keeping fan control.
 

AdoP

Well-known member
Joined
Aug 16, 2009
Messages
120
Location
Guelph/ Toronto
No I do not have the install disk but I have heard that there are specialized drivers on the disk. I will try 9-8 now hopefully that will work
 

MarkOne

Banned
Joined
Oct 19, 2009
Messages
4,010
Location
Chertsey 60 KM north of Montreal
I never install the disk one , only the 9.10 catalyst do you try to adjust in the catalyst ? do you go to the menu I show you . are you in basic or advance mod , it's make no sence , I remove the diamond sticker on my cooler and it's an OEM under with the sticker of ATI.. so exactly the same card
 

sswilson

Moderator
Staff member
Joined
Dec 9, 2006
Messages
17,899
Location
Moncton NB
I never install the disk one , only the 9.10 catalyst do you try to adjust in the catalyst ? do you go to the menu I show you . are you in basic or advance mod , it's make no sence , I remove the diamond sticker on my cooler and it's an OEM under with the sticker of ATI.. so exactly the same card
But not necessarily the same bios.

Did you do some digging on the riva tuner forums (guru3d) for forcing fan speeds? Fan speeds in CCC is a fairly new thing, and IIRC at one time we had to make a few registry changes through Riva Tuner to enable it on an ATI card.
 

AdoP

Well-known member
Joined
Aug 16, 2009
Messages
120
Location
Guelph/ Toronto
In rivatuner I can not even acess low level customize, I have version 2.24 (newest) and when I open rivatuner it says that the display driver is too new for this version of rivatuner but I am now trying 9-5 so it is an old driver.

See the screenshot below, GPUZ and overdrive think that the fan is spinning at 90% but it is actually spinning very slow. I am thinking that it is a bios/driver problem but now I have tried 9-5 through 9-10 so I am getting a little confused:doh:

 

sswilson

Moderator
Staff member
Joined
Dec 9, 2006
Messages
17,899
Location
Moncton NB
Does adjusting the fan control do anything at all? I'd start wondering about the bios on it as well if not. (Think I'd go for an aftermarket cooler before I started messing with it though).

If the 240 rpm is legit, that's pretty damn slow for a small(ish) fan.
 

Latest posts

Twitter

Top