What's new
  • Please do not post any links until you have 3 posts as they will automatically be rejected to prevent SPAM. Many words are also blocked due to being used in SPAM Messages. Thanks!

HTTP based downloads Slow. Anything else is fine?

Sagath

Moderator
Staff member
Joined
Feb 7, 2009
Messages
3,959
Location
Edmonton, AB
So today I was trying to grab a firmware update for my phone. It was downloading super slow @ 1mbps. I assumed it was just a bad server, and tried another site. Same speed.

So I ran a speedtest, came back fine. 60+mbps. Right where I should be. So I grab nVidias latest driver through Chrome. 1mbps...Thats strange. I check GOG and just grab anything. 1mbps. I'm thinking maybe its Chrome, and try to grab any of the same files through my NAS. They all work fine and cap out my ISP.

Now I'm thinking maybe its my PC having an issue, so I grab the firmware file I downloaded with the NAS, and it copies over at 100m/sec lickety split.

I'm REALLY stumped here at any ideas, and I have no clue when this began exactly.

OS is Win8.1
Network Realtek PCIe GBE family, driver 8.34.617.2014 but I dont suspect this is an issue due to the NAS capping out my network card/router...

Any thoughts?
 
Last edited:

Sagath

Moderator
Staff member
Joined
Feb 7, 2009
Messages
3,959
Location
Edmonton, AB
I should probably add some more info. Steam downloads fine, and internet explorer experiences the same thing, so I think this is some kind of network protocol (HTTP based downloads?) issue with windows.
 

Sagath

Moderator
Staff member
Joined
Feb 7, 2009
Messages
3,959
Location
Edmonton, AB
Clearly something hijacked my settings.

So some google-fu landed me on something about "MTU" problems and TCP optimization. That landed me here: SpeedGuide.net :: TCP Optimizer / Downloads

I downloaded the program, set my ethernet to 'optimal' hit apply, rebooted, and voila. Solved.

I'm going to edit the title name in the hopes that my mass confusion will help someone else out down the road.
 

Latest posts

Twitter

Top