What's new
  • Please do not post any links until you have 3 posts as they will automatically be rejected to prevent SPAM. Many words are also blocked due to being used in SPAM Messages. Thanks!

I H8 Pfsense: please help? BL3

CMetaphor

Quadfather
Joined
May 5, 2007
Messages
5,690
Location
Montreal, Canada
I've been trying for a week to get Borderlands 3 to work for coop play with a friend. And no matter what I do to my Pfsense router PC, the connection times out and fails.

I've been using this as a reference for the ports:
- from which I've added all the ports in the PC section as well as the Steam section (my friend and I both have BL3 on Steam).

But *nothing* works.
I've created rules in the NAT -> Port forward section for inbound Nat rules. I've created rules in the NAT -> outbound section for outbound Nat rules. And I've created firewall rules in the firewall section.

Every tutorial I read says I've done it all correctly, but half of them (or more) are for older versions of Pfsense. So if anyone has any experience getting all this crap to work, please let me know!

PS: Pfsense was a massive mistake. For the tiny bit of extra security, stability and speed it provides over a regular router, it absolutely was NOT worth it for the number of headaches caused by configuration woes.

I'll just say it: Pfsense feels like a router for level 3+ network admins to show off and flex the knowledge they learned in school, which is almost never applied elsewhere. Yep.
 

CMetaphor

Quadfather
Joined
May 5, 2007
Messages
5,690
Location
Montreal, Canada
@lowfat that's actually super helpful! And I've noticed one mistake I made:
Destination : Wan Address I had set to Lan address. I guess that's one of those things that's completely counter-intuitive?

What do you have for outbound NAT and firewall rules for the same case (Plex in your case) ?
 

lowfat

Moderator
Staff member
Joined
Feb 12, 2007
Messages
10,231
Location
Grande Prairie, AB
@lowfat that's actually super helpful! And I've noticed one mistake I made:
Destination : Wan Address I had set to Lan address. I guess that's one of those things that's completely counter-intuitive?

What do you have for outbound NAT and firewall rules for the same case (Plex in your case) ?
PfSense will automatically make the firewall rule when you forward the port. So this is the only thing I've done for Plex.

If you use PfBlockerNG then you may also need to whitelist other stuff for Plex.
 

CMetaphor

Quadfather
Joined
May 5, 2007
Messages
5,690
Location
Montreal, Canada
PfSense will automatically make the firewall rule when you forward the port. So this is the only thing I've done for Plex.
Oddly enough, and true story: my firewall rules were created, but never applied. I had to go to the firewall section on the router and apply the changes, or the generated rules would've never applied.

I'll check to see if the Wan vs Lan thing was the only part I messed up. Still seems counterintuitive but I honestly don't have a clue what else to do to make this ridiculous SW work properly.
 

lowfat

Moderator
Staff member
Joined
Feb 12, 2007
Messages
10,231
Location
Grande Prairie, AB
Oddly enough, and true story: my firewall rules were created, but never applied. I had to go to the firewall section on the router and apply the changes, or the generated rules would've never applied.

I'll check to see if the Wan vs Lan thing was the only part I messed up. Still seems counterintuitive but I honestly don't have a clue what else to do to make this ridiculous SW work properly.
After you create the port forward, a box at the top of the window will tell you need to apply before changes are made. After that both the rule and NAT will enable. Same thing for deleting the NAT, it will also delete the rule, after you click apply at the top. Just tested this and both worked.


You should be able to find how-to's for pretty much everything on PfSense since it has a pretty massive community. Some of them will be for the older interface. But the fields should all be mostly the same.
 

CMetaphor

Quadfather
Joined
May 5, 2007
Messages
5,690
Location
Montreal, Canada
Seems like your suggestion wasn't enough.
I tried getting the port forward rule for warframe updated and the game still throws a "strict Nat, please forward these ports" error at me at launch...
My port forward screen for the ports in question, 4950-4955, looks exactly the same as yours does now @lowfat , so there has to be something else. Can you show me your config on the NAT / outbound and Firewall Rules pages?
 

lowfat

Moderator
Staff member
Joined
Feb 12, 2007
Messages
10,231
Location
Grande Prairie, AB
Seems like your suggestion wasn't enough.
I tried getting the port forward rule for warframe updated and the game still throws a "strict Nat, please forward these ports" error at me at launch...
My port forward screen for the ports in question, 4950-4955, looks exactly the same as yours does now @lowfat , so there has to be something else. Can you show me your config on the NAT / outbound and Firewall Rules pages?
Don't use Outbound.
Code:
Automatic outbound NAT rule generation.

(IPsec passthrough included)
by default. Nothing else on the page was ever touched.

Do you have Pure NAT enabled?
In order to access ports forwarded on the WAN interface from internal networks, NAT reflection must be enabled.

In order to do this, navigate to System > Advanced, Firewall/NAT tab. On that page, select Pure NAT for NAT Reflection mode for port forwards, check Enable NAT Reflection for 1:1 NAT, and check Enable automatic outbound NAT for Reflection. Click Save.
I did this like 5 years ago, so forgot about some things. :cautious:
 

Latest posts

Twitter

Top