What's new
  • Please do not post any links until you have 3 posts as they will automatically be rejected to prevent SPAM. Many words are also blocked due to being used in SPAM Messages. Thanks!

MacBook Pro Audio Jack Static

Kommie986

Well-known member
Joined
May 30, 2010
Messages
601
Location
Waterloo, Ontario
I got a MacBook Pro for Christmas, which I am using for school ATM and I've noticed a pretty annoying issue. About 1/3 of the time when I have my earphones (Apple EarPods) plugged in, I hear static feedback. IDK how to fix it. I've tried turning the plug and unplugging then plugging it back in. The static is still there and just disappears after a while on its own. Anyone else have this kind of problem? Also, what should I do?
 

Arinoth

Moderator
Staff member
Joined
May 27, 2009
Messages
9,363
Location
Halifax
Does it happen to any ear phones or speakers plugged into it or just the ones you are using (Apple EarPods)

I had an issue using my phone head phones in computer speaker jacks since it has an extra connector for the mic which was causing the static feedback. Unless the device, such as a phone or tablet has the 3 connectors which include the microphone any headphones that have a mic in them will cause static feedback or some kind of distortion
 

Kommie986

Well-known member
Joined
May 30, 2010
Messages
601
Location
Waterloo, Ontario
Does it happen to any ear phones or speakers plugged into it or just the ones you are using (Apple EarPods)

I had an issue using my phone head phones in computer speaker jacks since it has an extra connector for the mic which was causing the static feedback. Unless the device, such as a phone or tablet has the 3 connectors which include the microphone any headphones that have a mic in them will cause static feedback or some kind of distortion

The MacBook audio port is in and out (like phone). I will use the earphones that were included with my Galaxy Nexus to test whether it's just an issue with my earphones.
Also, I called Apple Support and they instructed me to so some resets. Hopefully those work.
 

Kommie986

Well-known member
Joined
May 30, 2010
Messages
601
Location
Waterloo, Ontario
I think the problem may be with the earphones. I don't get the issue with the ones that came with my Galaxy Nexus. Looks like I gotta RMA some earphones 0_o
 

Latest posts

Twitter

Top