What's new
  • Please do not post any links until you have 3 posts as they will automatically be rejected to prevent SPAM. Many words are also blocked due to being used in SPAM Messages. Thanks!

MSI Radeon R9 280X no 3D

MARSTG

Well-known member
Joined
Apr 22, 2011
Messages
4,313
Location
Montreal
Hi guys,
So this morning I got my new folder, a MSI Radeon R9 280X, installed AMD 14.4 drivers, connected the 6 and 8 pin leads (PSU is Antec Earth Watts 650) card is powering up fine, folds fine (sometimes in excess of 150k PPD), overclocks fine, I have it stable at 1150MHz but 3D is not engaging. I cannot even refresh the WEI score. I wanted to play NFS2010, the configurator utility is not allowing me to select any resolution.
Previously I had a GTX 460 in the system, removed drivers, a few reboots, nothing. Win7 was installed a few days ago. This card as per se has some mixed reviews on newegg, only like 3/5 good, but I said most of the time I am not gaming, so it will not make a big thing out of it, but nonetheless I am a bit worried. Any suggestions?
 

zoob

Well-known member
Joined
Aug 21, 2007
Messages
1,663
Location
Toronto, ON
Only other suggestions - disable PCI-E link power mode (it messes up my Crossfire) and try underclocking lower and lower to see if that helps.

IIRC fishingfantic had issues with his 295X2 that were only resolved after a whole system reinstall, so perhaps a clean install on a test drive might help rule out software issues.
 

MARSTG

Well-known member
Joined
Apr 22, 2011
Messages
4,313
Location
Montreal
Solid point, will try next morning; so far 145k PPD on 9406WU!

New os installing right now.

A complete Win7 reinstall made 3D available! Thx Brian!
 
Last edited:

Latest posts

Twitter

Top