What's new
  • Please do not post any links until you have 3 posts as they will automatically be rejected to prevent SPAM. Many words are also blocked due to being used in SPAM Messages. Thanks!

New GTX 780 Ti no video signal, need help!

Derelict77

Member
Joined
May 21, 2014
Messages
22
Location
Vancouver, Canada
Sure seems that way Bond, now that I have tried two I am resigned to the fact that I either get a new motherboard along with a 780Ti or I may make one last effort along Charlie's suggestion and pick up one of the latest gen AMD cards to see what happens.

I have contacted ASUS too to see if they have any tech guru that can tell me why this is happening to this card/mobo combo too, though I don't expect much.

Once I get a new AMD or if some solution comes along I'll come back and update this thread.

Thanks for all the help guys!
 

Bond007

Well-known member
Joined
Jun 24, 2009
Messages
4,990
Location
Nova Scotia
Find a good 290 or 290x with a quality cooler (not reference) and it will still be a great card.
 

Derelict77

Member
Joined
May 21, 2014
Messages
22
Location
Vancouver, Canada
Going to give props to NCIX for letting me return another video card. Swapped out the 780 for an ASUS 290x DirectCU. Sadly after installing it the behaviour is exactly the same as the 780s, no video signal at all.

I am thinking something along these lines could be the issue http://forums.guru3d.com/showthread.php?t=387990. The BIOS' on the latest cards are likely not getting along with my motherboards BIOS, though I am not sure how to go about flashing a video card BIOS, especially when I can't see anything on screen.
 

stoanee

Well-known member
Joined
Jun 4, 2007
Messages
3,225
Location
Lacombe Alberta
After all the troubleshooting you have done I think it is time to bite the bullet and swap out that mobo.....
 

rjbarker

Well-known member
Joined
Feb 19, 2008
Messages
6,505
Location
Courtenay, B.C
^^^^^ Yep I would have gone that route prior to swapping out the 780Ti for the AMD Card ;)

OP....have you queried ROG (Republic of Gamers) with your issue, lots of great ASUS Support there, far better then ASUS itself!!
 

Derelict77

Member
Joined
May 21, 2014
Messages
22
Location
Vancouver, Canada
Just in the process of pricing out a new motherboard and processor actually :)

I would have preferred to keep the 780Ti, but now that it seems a mobo switch is needed the price difference to the 290X does pay for a sweet Z97 board on it's own.

I'll check out ROG see if they have any suggestions to get the current parts to get along. Thanks for the tip!
 

Zephiran

New member
Joined
Aug 14, 2014
Messages
2
I noticed a lot of our issues are similar (ASUS mobo, 780ti, no signal at all when gfx card is plugged in). Did you ever manage to resolve it?
 

Latest posts

Twitter

Top