What's new
  • Please do not post any links until you have 3 posts as they will automatically be rejected to prevent SPAM. Many words are also blocked due to being used in SPAM Messages. Thanks!

one stick of tripple channel ram not detected.

kyle_L

Well-known member
Joined
Nov 11, 2008
Messages
1,119
Location
Port Coquitlam, bc
i plugged in my ram today that i bought off here and one stick is not detected. it is mushkin 998692, which was reviewed here. i have tried the stick in 3 of the slots on my mobo with the other stick installed and could never see more that 4gb, i have tried the undetected stick by itself and my computer will not boot, any sugestion on what to try. how long should i run mem test on the other stucks to make shure theres nothing wrong with them eather.
 

stoanee

Well-known member
Joined
Jun 4, 2007
Messages
3,225
Location
Lacombe Alberta
Probably a dead stick. I have used lots of Mushkin with good results but the DDR3 kit I bought the other day has a bad stick also. Try each stick one at a time in each slot just to make sure.
 

Iamcanadian7

Well-known member
Joined
Aug 17, 2008
Messages
251
Location
Winnipeg, MB
Flash your BIOS to the latest version, this has fixed issues like that numerous times for me.

If it still doesn't detect after the flash, then it's a dead stick.
 

zoob

Well-known member
Joined
Aug 21, 2007
Messages
1,655
Location
Toronto, ON
Which board do you have? On the Rampage 2 Gene that I have, it instructs you to start filling up the RAM on a certain slot keeping the same colour. Also you may have to re-seat your CPU - sometimes if the pads aren't making enough contact to the LGA it will lose a channel for the RAM.
 

Arinoth

Moderator
Staff member
Joined
May 27, 2009
Messages
9,234
Location
Halifax
Sounds like its not the ram itself but the compatibility of the ram and the mobo. For some reason the 1366 boards only like certain ram per board.
 

Twitter

Top