What's new
  • Please do not post any links until you have 3 posts as they will automatically be rejected to prevent SPAM. Many words are also blocked due to being used in SPAM Messages. Thanks!

PC unable to post... DRAM orange/yellow light

azx2k

New member
Joined
Jul 17, 2021
Messages
4
Hey all first time builder for my rig...


ASUS TUF B550M-PLUS (non wifi) moba
GSKILL Trident RAM 3200mhz 2x8gb
ASUS 3080 OC TUF
Ryzen 5600x processor

So I've managed to hook everything up however when I press the power button everything lights up etc. but the peripherals, mouse... keyboard, monitors don't open however the DRAM light on the mobo is also on

I've looked into it on google and asked a few mates as well.

1) I don't think its a RAM issue as I've tried 2 different sticks of RAM which both don't work, however both work on my ASRock B450M current build (I have put back my old mobo for now :( )
2) I have tried the CSOM reset etc. and removed the battery as well
3) I have also tried using 1 stick of RAM (RAM have always been in the correct slot A2 and B2)

All of the above still giving me the DRAM light :(

Leads me to two possible conclusions...
Either the RAM spacing on the MOBO is faulty OR the RAM isn't inserted properly? My bro told me he had htis issue before and resolved it by ensuring two clicks are heard to know its properly seated and to hear for 'two clicks'. When I insert the sticks it is with decent force as I do notice the mobo pushing downwards a bit... I do hear one click on hte left hand side but the right hand side where the lever is does go up but does not click or seal itself... I have to kind of give it one more gentle push in and it clicks does that mean its not properly seated??

Thanks :(
 

azx2k

New member
Joined
Jul 17, 2021
Messages
4

It sounds like you've got the right slots, but just to be sure.... the single stick should be placed in "B2" which is the slot furthest from the CPU (The manual doesn't really make it clear what the orientation of the slots is WRT the CPU).
Yeh I left the furthest one away the CPU in, still doesn't work :(
Might try to re-seat the RAM again tmr... but will mean have to take apart my PC again and insert everything
 

azx2k

New member
Joined
Jul 17, 2021
Messages
4
Have you tried using BIOS Flashback to update to the latest BIOS? I see the 5600X wasn't supported until v1004 and the latest is v2403. Could be the board has too old of a BIOS to support the CPU currently.
Oh I've not done this... I assumed cos the 5600x and the B550M-Plus are both new so it would support it automatically. The box even states it can support 3rd gen Ryzens like hte 3600 :eek:
 

azx2k

New member
Joined
Jul 17, 2021
Messages
4
Have you tried using BIOS Flashback to update to the latest BIOS? I see the 5600X wasn't supported until v1004 and the latest is v2403. Could be the board has too old of a BIOS to support the CPU currently.
Turns out you may be right.... just saw my mobo the last 4 digits on the barcode is 0320 which correlates to May 2020 ie before Ryzen 5600x came out in Nov 2020... will flash the bios tmr and hopefully it works ><
 

Latest posts

Twitter

Top