What's new
  • Please do not post any links until you have 3 posts as they will automatically be rejected to prevent SPAM. Many words are also blocked due to being used in SPAM Messages. Thanks!

PCIe to SATA card not recognizing drives.

Dusty42701

New member
Joined
Feb 1, 2018
Messages
1
So I have a low-power system that runs 24/7 and is used mostly for copying discs into onboard storage and hosting it to the network. The system consists of a N3150 Mini-ITX motherboard, I forget the exact model, a DVD-RW drive, and two WD reds. Now this board only has two SATA ports, one going to the DVD drive, and the other going to the OS drive (WD red). This board has a single PCIe x16, so I thought I'd just use a PCIe SATA adapter for the other Red.

So here lies the problem. Many days later skimming over BIOS settings, fighting with every combination of drivers I can think of (after manufacturer instructions proved ineffective), third card later, still no good. Mind you, I am not using this as a bootable, this is just to connect a 3TB WD red as storage.

I have tried an OE Dell SAS host adapter with SATA cable. Can't initiate.

Tried ordering a different adapter, a generic LSI-9211 with the same cable. Installs and the marvell utility it came with can access it, but it won't recognize the drive.

Finally, I decided to go for an actual SATA card instead of a SAS adapter. Picked up a generic IOCrest PCIe to 4-port SATA 6G card (Says it's a Marvell 9215.) Same thing. Comes with a marvell disc, installs, able to view the card stats and version numbers in marvell utility, but still can't find any drives. Partition utility in windows cannot see it either. Device manager says "device cannot start".

To rule out having a bad drive, I tested that with a USB bridge and the same SATA cable that is plugged into the card and I am able to view all of the files currently on the drive.
Am I missing something? Is there some voodoo magic to making this work, or is it just not going to work with this motherboard??
I will add that I never do get a card BIOS screen... Ya know, the one where you hit Ctrl+s or m to manage the disks? I'm not sure if that is a clue or not.

<iframe allowfullscreen="true" mozallowfullscreen="true" webkitallowfullscreen="true" style="height: 500px; width: 540px; margin: 10px 0px; padding: 0px;" class="imgur-embed-iframe-pub imgur-embed-iframe-pub-a-lPHF8-true-540" scrolling="no" src="http://imgur.com/a/lPHF8/embed?pub=true&ref=http%3A%2F%2Fwww.hardwarecanucks.com%2Fforum%2Feditpost.php%3Fdo%3Deditpost%26p%3D863005&w=540" id="imgur-embed-iframe-pub-a-lPHF8"></iframe><script async="" src="//s.imgur.com/min/embed.js" charset="utf-8"></script>
 
Last edited:

KaptCrunch

Well-known member
Joined
Feb 23, 2008
Messages
4,079
Location
Ontario
use the motherboards app for updating software / firmware to get the correct bios file

if use wrong one you'll make a paper weight out of the computer

read all info on flashing bios and check the MB Revision # that's printed on the board ...RevX.XX

cause some times manu use same model # with different chips like using chevy or ford motor to drive your car
 

djbrad

Well-known member
Joined
Oct 14, 2012
Messages
83
Hi,

I have some Zotac atom 330 motherboard in the same usage as you : boot as ssd, store to WD 6TB green as htpc, rip with the dvd rom (this mb has 3 sata onboard and 1 one esata).

It never played well with x64 os, so I got windows 7 x86 on it.

Tried Linux Mint x64 18.x on it, and it was not a great success.

I sugget to try to some livelinux cd, in x86 and in x64 flavor, to test if it is really a driver problem, or if that pci-e slot is reserved to GPU or soundcard.

You should be able to read the drive on them, and if not, that slot won't cooperate at all.

There's could be an hint about it in the manual.

Bios update should be at a last resort.

Just waiting for the 2400g to comeout to replace this running 24/7 htpc since 2009, wow time flies.

Good luck!
 
Error 403 Daily Limit Exceeded. The quota will be reset at midnight Pacific Time (PT). You may monitor your quota usage and adjust limits in the API Console: https://console.developers.google.com/apis/api/youtube.googleapis.com/quotas?project=345236864347 : dailyLimitExceeded

Latest posts

Twitter

Top