What's new
  • Please do not post any links until you have 3 posts as they will automatically be rejected to prevent SPAM. Many words are also blocked due to being used in SPAM Messages. Thanks!

sata hard drive formatting issue in XP

sirhc

Active member
Joined
Sep 27, 2008
Messages
29
Just received my parts for my new build, got it all assembled and set the bios up? went to install XP and it needed to format my 500gb sata hard drive and after 40 minutes it came back saying it could not do it .. to full or damaged or?? Bad hard drive? That would suck another 3 week wait! Any ideas? I did not use the f6 because the bios saw my hard drive???
 

arekieh

Well-known member
Joined
Oct 2, 2008
Messages
793
Location
Edmonton
Hey man,
Dont give up, before you do try formatting with a live linux cd like gparted. Its basically a linux kernel thats solely for editing partitions and formatting drives. Handy program.
GParted -- Welcome

If that doesnt work, i would send the drive in for an RMA
Good luck
 

enaberif

Well-known member
Joined
Dec 9, 2006
Messages
11,391
Location
Calgahree, AB
Did you do a full format or a quick format?

Full format does a check of the disk to confirm everything is good. If this fails then generally there is a problem with the drive.
 

sirhc

Active member
Joined
Sep 27, 2008
Messages
29
first build issues with sata and XP

I will confirm but pretty sure it was set as raid and not ide and did the full not the quick .... ordered from NCIX will local Computer stores replace the drive for me or does it have to go back to NCIX?
 

Tazer-[X]

Well-known member
Joined
Jul 8, 2008
Messages
555
Location
Terrace, BC
Well, you could always forget about all the neato little apps and stuff and go back to basic, get a win98 start up disk. sounds strange, but, its bout the best tool ive ever had to scramble for.
 

sirhc

Active member
Joined
Sep 27, 2008
Messages
29
in the bios it says "sata ahci" => should this be enabled or disabled when plan is to use XP?

also "sata port 0-3 native mode" => should this B enabled or disabled?

I disabled the serial and parralel ports

what about the onboard IDE controller?

The hard drive shows up under IDE channel 0 master and the CDROM shows up under IDE channel 1 master ... ??

Any ideas as to what they should show as?
 

sirhc

Active member
Joined
Sep 27, 2008
Messages
29
in the bios it says "sata ahci" => should this be enabled or disabled when plan is to use XP?

also "sata port 0-3 native mode" => should this B enabled or disabled?
Originally I had these set to disabled because I read somewhere that XP has a problem with sata drives and the bios detected both my DVD rom and HD, I tried switching to AHCI and enabled and my bios did not find my harddrive and DVD rom?

The problem was that XP could not format my 500 GB HD ... I was only using a single partition "C" I am guessing it is a bad hard drive .... how can I be sure?
 

arekieh

Well-known member
Joined
Oct 2, 2008
Messages
793
Location
Edmonton
As i said, run gparted
and try formatting it with it. Gparted has fix many "ruined" drives for me
 
Top