What's new
  • Please do not post any links until you have 3 posts as they will automatically be rejected to prevent SPAM. Many words are also blocked due to being used in SPAM Messages. Thanks!

Sony VIAO support.....questionable.

Pelt

Well-known member
Joined
Apr 7, 2009
Messages
348
Location
Stewiacke, Nova Scotia
So a few months back I had a strange problem with my Sony VIAO laptop, it won't come out of hibernation mode properly. Basically I couldn't wake it up and no amount of restarting would solve the problem. So I called support and they we're nice and somewhat knowledgeable but couldn't help me with the problem over the phone so I had to send the laptop in for repair, no problem off it went.

A few weeks later the laptop returns unfortunately I was away up north so it wasn't until a week or so ago when I returned that I got to play with my repaired computer. First thing I noticed was that they reset the machine to factory settings, basically reloaded the OS with all the wonderful bloat ware. The computer was stupid slow which was driving me nuts. The specs of the laptop are...Intel I7 1.67GHZ chip, 8GB of 1066 RAM, Blu-ray drive and wireless N network. So the laptop should be pretty quick, and it was prior to sending it in for repair. Today was the last straw I reloaded my version of windows 7 pro 64bit in an attempt to rid the system of the crapware I wrongly thought was slowing down the computer. Upon finishing my reboot I went into system information to activate windows when I noticed that my machine only had 2GB of RAM listed for system memory :shok:.

Then it all clicked of course it had to be the RAM slowing down the machine it makes perfect sense why didn't I check this before! Then I thought maybe one of the RAM chips is dead I'll take a look. I opened up the machine and low and behold 2 1GB RAM chips are staring back at me...WTF.

So of course I know when I call Sony I'll be in for a fight right? Right I call them up and start the battle. They say they reinstalled everything and that I must have switched the RAM (didn't see that coming eh?). I call bullshit and tell them to have one of there customer mediation people call me to disscuss how we can rectify this. I'm pretty pissed right now, there is nothing worse for me than being called a liar and a cheat by a muti million dollar company. I'm so livid I wish I could acurately convey the poor treatment I recieved from Sony this morning but I've got to chill out a bit first.
 

Deviant

Well-known member
Joined
Jul 16, 2009
Messages
349
Location
UWO :D or Toronto
Actually, from what I've heard, when your Vaio works, it's just great. But when it comes time to support as seen on notebookreview forums, Sony finds ways to get themselves out of the problem by blaming the customer. You got to keep at it otherwise they'll consider you a pushover.
 
Top