What's new
  • Please do not post any links until you have 3 posts as they will automatically be rejected to prevent SPAM. Many words are also blocked due to being used in SPAM Messages. Thanks!

Sound Cards and Win7

crispex

Well-known member
Joined
Mar 13, 2009
Messages
283
Location
Tempe, AZ
They don't seem to play nice, haha.

The problem: whenever a sound in a game or other application plays that the sound card doesn't like, the given program freezes. It happens quite a bit more than I can simply ignore.

Fun driver issue, I guess.

I am currently using an Auzentech Forte in league with Win7. I already have the driver here: Auzentech, Inc. Sound Cards. Audio You Can Believe In. World First soundcards for Music, HTPC, and Gaming.

...and really cant think of anything else there is that I can do.

If you know of any drivers (or anything, really) that work better for this card/OS combo, please speak up.
 

Squeetard

"Quote This..."
Joined
Nov 15, 2007
Messages
3,984
Location
Hell
Probably the drivers. I've had my Creative x-fi gamer on both 32 and 64 bit Win7 for 6 months now and zero issues. Started with the vista drivers and now am running the win7 betas.
 

JD

Moderator
Staff member
Joined
Jul 16, 2007
Messages
8,915
Location
Toronto, ON
Creative is notorious for bad drivers and well since that Auzentech is using a X-Fi chip I guess you're experiencing some. I doubt Creative puts as much effort into making drivers for Auzentech as they do for their own cards.
 

Nodscene

Well-known member
Joined
Dec 7, 2007
Messages
1,015
Location
Toronto
I haven't had any issue's whatsoever with my Prelude and Windows 7 RC1 x64. I used the latest ones from the Auzentech site. Keep in mind though that I don't really play any games so I haven't tested that aspect yet.

I did run across this howto while I was doing some research, not sure if it will help you or not but may be worth a try...

Auzentech X-fi Prelude drivers for Windows 7 Beta - Guru3D.com Forums
 

Inik

Well-known member
Joined
Aug 17, 2007
Messages
1,951
Location
Montreal
I played some games on Win 7 64 with my Auzentech Prelude without any problems. I use the driver on their website.. maybe try to reinstall it and use Driver cleaner?
 

Latest posts

Twitter

Top