What's new
  • Please do not post any links until you have 3 posts as they will automatically be rejected to prevent SPAM. Many words are also blocked due to being used in SPAM Messages. Thanks!

TP-Link wr740n

celestialguy

Member
Joined
Jul 14, 2009
Messages
9
I bought tp-link wr740n wireless router about 10 days ago at ncix. But recently the wireless is acting funny. It will give out IP addresses via dhcp; but after anywhere from 5minutes to an hour no wireless devices that's already connected can access the internet nor the local network. PCs will say it's connected (the bottom right icon still has a globe) but it will not work. Using network diagnostic on windows pc, it says the wireless router is not responding. Disconnecting the pc from the network and reconnecting does not work. It will say "network unavailable" but the network can be seen in the list of wireless networks.

The only way to fix this is to restart the router. I have updated to the latest firmware (3.12.11 I think) and the hardware is ver.4.

I suspect it's a faulty wireless chip. Any suggestions?
 

Agent-A.01

Active member
Joined
Nov 29, 2010
Messages
26
does it overheat or anything? that seems to be a common problem for some routers..
 

celestialguy

Member
Joined
Jul 14, 2009
Messages
9
No it doesn't seem hot to the touch. I brought it back to NCIX exchanged for a new one and it works perfectly fine.

Thanks for the help though!

EDIT: After testing the replacement for a few days. It has the same problems as the first one. :sad: I found another workaround is to disable and re-enable the wireless NIC on the computers and they will connect to the wireless network again.
 
Last edited:

Latest posts

Twitter

Top