What's new
  • Please do not post any links until you have 3 posts as they will automatically be rejected to prevent SPAM. Many words are also blocked due to being used in SPAM Messages. Thanks!

Unicorn

MrDeodorant

Member
Joined
Nov 4, 2008
Messages
19
This isn't really a new build, just an upgrade, but it turned out to have such drastic consequences that I really do almost have a new computer.

Recently, I discovered that without any sort of airflow over my northbridge heatsink, it gets too hot to touch, so I decided to buy a Swiftech MCR-30 waterblock, and an Enzotech MST-81 MOSFET heatsink.

Note: this is also being posted on Overclock.net, but it's being posted on Hardware Canucks first, because Canada rules.

My computer, tastefully nude.





The MCR-30. What you aren't seeing inside the waterblock are the ridges and fins; that's because there aren't any. It's just a copper plate with water running over it. Hopefully it'll work out well enough.





Turns out the MCR-30 doesn't actually fit Asus P5Q motherboards, but by unscrewing a pair of screws, you can make the mounting arm swing out, and since it only needs a few millimeters more, I have done so.





The MCR-30 came with 1/2, 3/8, and 1/4 inch fittings, plus clamps and a teeny applicator of thermal compound. With all the mounting hardware that came with it, Swiftech has done a great job of preparing you for everything.





My waterblock had some crap stuck in the pins. Probably residue from the HW Labs radiator that got installed without (I think) being flushed first. Flush your radiators! My waterblock also smelled pretty bad, so I think it was starting to get some algae going.





Precipitate and other gunk in my old water.





Here's where my tale turns cautionary: this can happen to the best of us.




That's the plastic scratch protector. It's been on there for two processors, and it's the reason my temperaturs used to climb into the 70s range even with two radiators.

After removing it and remounting my water block, my CPU idles at 29 degrees, and it's at 44 degrees under ORTHOS. It was previously temperature capped at 3.6 GHz, but now it's sitting happily at 4.05, and I'll see how much higher I can take it over the weekend.
 

MrDeodorant

Member
Joined
Nov 4, 2008
Messages
19
Yeah, I'm surprised it even let me clock to stock speeds, but I had actually been overclocking for ten months with that thing on.
 

MrDeodorant

Member
Joined
Nov 4, 2008
Messages
19
Distilled water, a bit of Water Wetter, Iodine, and some Danger Den UV-Clear Blue dye. The dye, by the way, is now liberally coating every component in my loop with a thin particulate. I wonder why it isn't in stock at NCIX any more?
 

MrDeodorant

Member
Joined
Nov 4, 2008
Messages
19
Update: I've clocked it to 4.2 GHz, at 1.35 volts and about 45 degrees under ORTHOS. I have to bump the voltage for stability, but the temperature is low and Windows started smoothly, so I should be able to push it a little further without breaking 1.4.
 

Latest posts

Twitter

Top