What's new
  • Please do not post any links until you have 3 posts as they will automatically be rejected to prevent SPAM. Many words are also blocked due to being used in SPAM Messages. Thanks!

USB and wireless networking issue

BootlegUsher

Well-known member
Joined
Dec 14, 2009
Messages
482
Hello Hardware Canucks experts, I could use your help with two issues I am having with a new piece of wireless networking hardware.

I recently purchased an ASUS USB-AC55 network adapter. The router in the house is an ASUS RT-AC68U. I installed the adapter using the latest software from ASUS's website.

1. When I plug the adapter into one of my motherboard's USB 3.0 slots it shows as connecting to the network for a few seconds, but then dies and all networks disappear. When I plug the adapter into a USB 2.0 port in connects to the network fine, but gives me a message saying "this device could perform faster if connected to a hi-speed USB 3.0 port".

2. When I am connected, the wireless network information says that I am connected to "radio type 802.11n".

To summarize, I have an AC capable router with an AC capable adapter but it says I am in N mode. I have USB 3.0 ports on my motherboard but the adapter does not work when connected to them. The adapter is USB 3.0 capable.

I have this motherboard:
Motherboards - M4A87TD/USB3 - ASUS

Here is what I have done so far to try and fix the issue:

1. I updated the BIOS to the latest version.
2. I installed the USB 3.0 drivers (NEC Electronics Corporation USB3.0 Controller Driver V1.0.19.0 for Windows 32/64bit XP & 32/64bit Vista & 32/64bit Windows 7.(WHQL)
3. I went into my router's settings and made sure that the network I am connecting to is set to "auto" which means that AC, N, G and B devices can all connect to it. The other options were legacy and N+AC. I tried N+AC but this did not change anything.

How can I get the network to show as running in AC mode, and how can I get the USB 3.0 ports to work? Any help is appreciated.

Sincerely,

Bootleg Usher
 

JD

Moderator
Staff member
Joined
Jul 16, 2007
Messages
9,101
Location
Toronto, ON
What link speed are you getting? If it's over 450Mbps, then it's AC. Not sure if it would say as such or not regardless.

Are you using the latest drivers for the adapter? Latest router firmware?

Also, if any N/G devices are connected, it might drop this AC device down to N too. Maybe turn off all your other devices?
 

Sagath

Moderator
Staff member
Joined
Feb 7, 2009
Messages
4,009
Location
Edmonton, AB
The USB 3 problem sounds driver related. I know you said you've got the proper drivers, but it still sounds driver related. That being said, USB2 is more then sufficient bandwith for an AC device, so dont fret it too much if you cant seem to fix it.

I would turn off everything but N and AC channels on the router. Like JD said if your link speed is high its AC. However, both your devices can utilize dual band N+AC to get more speed out of your wifi. Alternatively, to check that it IS using AC you can disable the 2.4Ghz band, and just run AC off the 5Ghz. You have not incentive to keep B/G enabled, unless you have some really legacy devices on your network? Try data transfering between devices with large file transfers and see what speeds you're getting.

I'm getting about 20MB/sec (~200Mbit) on my AC network, but wifi is NOTORIOUSLY fickle between people. You can talk to 50 different people and they'll all get 50 different network speeds.

So, TLDR is this: Disable your 2.4ghz, and see what happens. Do a full uninstall of your USB3 drivers, and try different drivers. Do some googling to see if others have the same issue.
 

edgxunil

Active member
Joined
Jan 18, 2015
Messages
25
Location
GVR
Is it possible to try a PCI wireless network adapter instead of relying on the USB 3.0 port? If the PCI performs poorly and can not get to ac speed, then you know it's the router that's causing the problem. As for the USB 3.0 port, uninstall the default driver then reinstall an updated one, after that, transferring a large file on to a USB thumb drive, see if the speed is upto the 3.0 standard.
 

Latest posts

Twitter

Top