What's new
  • Please do not post any links until you have 3 posts as they will automatically be rejected to prevent SPAM. Many words are also blocked due to being used in SPAM Messages. Thanks!

Why is this Corsair Vengeance RAM not supported on any mobo?

fubar

Well-known member
Joined
Jan 18, 2012
Messages
528
Ok the build is complete while everything is running smoothly, sure enough the RAM is running at only 2133. I must admit, i'd really like to get that running faster but I've heard some horror stories with people using XMP with Ryzen builds, and especially Gigabyte mobos which I have. What would be your suggested way to bump up the speed without using XMP?
Why don't you want to use XMP? The 'problem' is that you have 4 sticks - it doesn't matter what mobo make or memory you have - when you have 4 sticks, it doesn't 'behave' with Ryzen systems. It's also not a very common configuration. I have online searched this stuff...I have an idea to have virtual machines so I tried to research this situation. That's all that is going on.... if you tried with 2 sticks, you'd probably be up and running - (meaning specified speeds or very close to it) did you try this yet just to confirm?

I forget the specifics but it's the way Ryzen/AMD and memory work when it's 4 sticks... you have to do more manual tinkering. Eventually, it will work. Corsair and G.Skill are both very good - and you picked a good mobo. Just be patient and google search this - and you will find some answers. I just can't recall what you do, exactly, but you probably have to make some manual settings changes. Nothing complicated. You might check the Gigabyte forums and try a youtube video search for using 4 memory sticks with Ryzen.


P.S. the 2133MHz speed is also common to start from (i.e. OOTB defaults). I forget which mobo make it is but they list in their QVL, that exact (starting) speed along with the other specified speeds that have been tried/tested which worked.
 

Caldezar

Well-known member
Joined
Aug 21, 2008
Messages
2,252
Location
Edmonton Area
I'm running my Corsair Vengeance RAM on Ryzen 2 using the 2933 XMP profile and I have zero issues. I'm running 2 sticks though, so perhaps that is a difference as mentioned? I know that quite a number of Intel platforms require a slight bump in voltage for 4x RAM sticks to run without issue, could be a similar situation here. Try 2 sticks, and if you have no issues, then check the voltage requirement on the RAM and set that manually in the BIOS and try 4 again.
 

CJ_Zak

New member
Joined
Nov 1, 2018
Messages
4
Success!

Just an update for anyone else with the same issue; it should be noted that my experience was very limited (this was my first build. I had never even been in to BIOS settings before!) Anyway I quit being such a wimp and went in to the BIOS and set XMP in the BIOS to 3000 left everything else at auto and ping! my RAM runs at 3000 :) ....well technically 2998 but hey - it's a hell of a lot better than 2133. Very happy...not to mention relieved. Thanks for all your help :) Can't believe how easy this was, I shouldn't have got so spooked out by horror stories.
 
Last edited:

Latest posts

Twitter

Top