What's new
  • Please do not post any links until you have 3 posts as they will automatically be rejected to prevent SPAM. Many words are also blocked due to being used in SPAM Messages. Thanks!

Windows 10 problem

Finch

Well-known member
Joined
Mar 29, 2008
Messages
262
Location
Montreal
I don't suppose you've got easy access to a team green card do you? If you do, and the behaviour doesn't exhibit itself with an NVidia card installed then it's pointing towards something in the AMD drivers (or as Sagath alluded to... something funky going on with windows trying some fancy dual GPU configs like you'd see on a laptop).
yeah also tried a gtx 560 :(

Disable the igpu in the bios.
i can't find any options to disable in bios. only thing i can do is switch the primary video from auto, igpu or pci-e and I already tried that

thanks guys for trying to help i really appreciate it and i know it is not an easy one
 

sswilson

Moderator
Staff member
Joined
Dec 9, 2006
Messages
19,309
Location
Moncton NB
yeah also tried a gtx 560 :(



i can't find any options to disable in bios. only thing i can do is switch the primary video from auto, igpu or pci-e and I already tried that
Ahhh... sorry I didn't pick up on that. I saw RX 570, and just assumed the 560 was also an RX.

Sometimes there's an option for completely disabling the onboard in the CPU/overclocking settings as opposed to the general settings where you're seeing the "primary graphics option".
 

Finch

Well-known member
Joined
Mar 29, 2008
Messages
262
Location
Montreal
Ahhh... sorry I didn't pick up on that. I saw RX 570, and just assumed the 560 was also an RX.

Sometimes there's an option for completely disabling the onboard in the CPU/overclocking settings as opposed to the general settings where you're seeing the "primary graphics option".
I searched everywhere there is really no option to disable it

update: it is really a conflict between igpu and dgpu. I reinstalled vanilla windows, then in device manager i see 2 display, one had a ! mark. then installed amd drivers restarted and the rx 570 was identified but one had still a ! mark. then installed officiel intel hd drivers and voila! hangs on driver installation.

i need to find a way to permanently disable the igpu and hope it will fix the issue
 

sswilson

Moderator
Staff member
Joined
Dec 9, 2006
Messages
19,309
Location
Moncton NB
I searched everywhere there is really no option to disable it

update: it is really a conflict between igpu and dgpu. I reinstalled vanilla windows, then in device manager i see 2 display, one had a ! mark. then installed amd drivers restarted and the rx 570 was identified but one had still a ! mark. then installed officiel intel hd drivers and voila! hangs on driver installation.

i need to find a way to permanently disable the igpu and hope it will fix the issue
If you can't find a setting in bios your only option might be trying to disable it in device manager.
 

Finch

Well-known member
Joined
Mar 29, 2008
Messages
262
Location
Montreal
If you can't find a setting in bios your only option might be trying to disable it in device manager.
Fail, back to square one

amd rx 570 driver installed, reboot, disabled igpu in device manager, reboot, confirmed igpu is still disabled, connected internet, freeze again and just before that i see in message center, windows trying to configure video driver

dang
 

Sagath

Moderator
Staff member
Folding Team
Joined
Feb 7, 2009
Messages
4,526
Location
Edmonton, AB
I searched everywhere there is really no option to disable it

update: it is really a conflict between igpu and dgpu. I reinstalled vanilla windows, then in device manager i see 2 display, one had a ! mark. then installed amd drivers restarted and the rx 570 was identified but one had still a ! mark. then installed officiel intel hd drivers and voila! hangs on driver installation.

i need to find a way to permanently disable the igpu and hope it will fix the issue
I feel very vindicated. This one was racking my brain. I'll pat myself on the back, dont worry guys.

 

Finch

Well-known member
Joined
Mar 29, 2008
Messages
262
Location
Montreal
I feel very vindicated. This one was racking my brain. I'll pat myself on the back, dont worry guys.

i confirm that there is no real disable feature in the bios i can only switch from igpu to pci-e or auto. that being said, even when it was set to pci-e windows was still seing it... and also tried to install drivers for it. there is no way around unless we find a way to stop this specific driver to be installed.

now i don't know what i did but it works for now. Remember i said in the previous post that i disabled the igpu in device manager, well it didn't stop windows to install the driver and re-enabling it by its own because now its fully identified with lastest driver installed and active, but for some reason it works because i am connected to the dgpu and windows is doing all its other updates as we speak. why? i don't know. will the problem rise again? maybe. Sure thing is this is a lot of trouble.
 

Finch

Well-known member
Joined
Mar 29, 2008
Messages
262
Location
Montreal
thanks guys for all the help. It's really the maximum we can do i think. Hope i don't have to reformat and try to figure it all out again. I think i was lucky that it works because i don't even know how i did lol
 

Sagath

Moderator
Staff member
Folding Team
Joined
Feb 7, 2009
Messages
4,526
Location
Edmonton, AB
Perhaps now that you know its the iGPU driver specifically, you can hide it, or block it using the policy editor?


Although if disabling it via Device manager solved it...thats pritty much the same end result I guess!
 

Finch

Well-known member
Joined
Mar 29, 2008
Messages
262
Location
Montreal
Perhaps now that you know its the iGPU driver specifically, you can hide it, or block it using the policy editor?

i did try fiddling in the policy editor the first time and all i found was to disable ALL drivers, not this specific one. Can you find the specific one i should try? the terms are a little bit complicated
 

Latest posts

Twitter

Top